The app works best with iOS10.3 and Android 7.1.1 (for most Android phones). We do not actively support iOS8 and earlier versions, or Android 4.4 and earlier versions.